La solución a este problema es instalar el siguiente paquete.

$ sudo apt-get install libpq-dev

Fuente:

http://stackoverflow.com/a/34672865