Abrimos la terminal y escribimos el siguiente comando:

$ yum install git

Aparecerá un mensaje similar a este:

Loaded plugins: fastestmirror
base                                                     | 3.7 kB     00:00
base/primary_db                                          | 4.4 MB     00:12
extras                                                   | 3.4 kB     00:00
extras/primary_db                                        |  19 kB     00:00
updates                                                  | 3.4 kB     00:00
updates/primary_db                                       | 826 kB     00:08
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package git.x86_64 0:1.7.1-3.el6_4.1 will be installed
--> Processing Dependency: perl-Git = 1.7.1-3.el6_4.1 for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl >= 5.006 for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: rsync for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(warnings) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(vars) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(strict) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(lib) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(Git) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(Getopt::Long) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(File::Spec) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(File::Find) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(File::Basename) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(Exporter) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(Error) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(Cwd) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: /usr/bin/perl for package: git-1.7.1-3.el6_4.1.x86_64
--> Running transaction check
---> Package perl.x86_64 4:5.10.1-136.el6 will be installed
--> Processing Dependency: perl-libs = 4:5.10.1-136.el6 for package: 4:perl-5.10.1-136.el6.x86_64
--> Processing Dependency: perl-libs for package: 4:perl-5.10.1-136.el6.x86_64
--> Processing Dependency: perl(version) for package: 4:perl-5.10.1-136.el6.x86_64
--> Processing Dependency: perl(Pod::Simple) for package: 4:perl-5.10.1-136.el6.x86_64
--> Processing Dependency: perl(Module::Pluggable) for package: 4:perl-5.10.1-136.el6.x86_64
--> Processing Dependency: libperl.so()(64bit) for package: 4:perl-5.10.1-136.el6.x86_64
---> Package perl-Error.noarch 1:0.17015-4.el6 will be installed
---> Package perl-Git.noarch 0:1.7.1-3.el6_4.1 will be installed
---> Package rsync.x86_64 0:3.0.6-9.el6_4.1 will be installed
--> Running transaction check
---> Package perl-Module-Pluggable.x86_64 1:3.90-136.el6 will be installed
---> Package perl-Pod-Simple.x86_64 1:3.13-136.el6 will be installed
--> Processing Dependency: perl(Pod::Escapes) >= 1.04 for package: 1:perl-Pod-Simple-3.13-136.el6.x86_64
---> Package perl-libs.x86_64 4:5.10.1-136.el6 will be installed
---> Package perl-version.x86_64 3:0.77-136.el6 will be installed
--> Running transaction check
---> Package perl-Pod-Escapes.x86_64 1:1.04-136.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                    Arch        Version                 Repository
                                                                           Size
================================================================================
Installing:
 git                        x86_64      1.7.1-3.el6_4.1         base      4.6 M
Installing for dependencies:
 perl                       x86_64      4:5.10.1-136.el6        base       10 M
 perl-Error                 noarch      1:0.17015-4.el6         base       29 k
 perl-Git                   noarch      1.7.1-3.el6_4.1         base       28 k
 perl-Module-Pluggable      x86_64      1:3.90-136.el6          base       40 k
 perl-Pod-Escapes           x86_64      1:1.04-136.el6          base       32 k
 perl-Pod-Simple            x86_64      1:3.13-136.el6          base      212 k
 perl-libs                  x86_64      4:5.10.1-136.el6        base      578 k
 perl-version               x86_64      3:0.77-136.el6          base       51 k
 rsync                      x86_64      3.0.6-9.el6_4.1         base      334 k

Transaction Summary
================================================================================
Install      10 Package(s)

Total download size: 16 M
Installed size: 51 M
Is this ok [y/N]:

Usted deberá precionar la tecla y y luego precionar la tecla Enter para que inicie el proceso de descarga e instalación.